Switcher website, Dashboard, Catalog, Collections, and Remote Guest services down

Incident Report for Switcher Inc.

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 13:46 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2025 - 11:40 EST

Identified

CloudFlare, Switcher's service provider for Website, Dashboard, Catalog, Collections, and Remote Guest services, is currently experiencing a widespread outage. This outage is affecting users' ability to sign into the Switcher Dashboard, use the Remote Guest feature in the Switcher app, and livestream to Collections and Catalogs. Collection and Catalog embeds on customer websites are not working.
Posted Nov 18, 2025 - 09:53 EST
This incident affected: Services (Switcher API, Switcher Dashboard, Switcher Player), Apps (Switcher Studio App), and Web (Switcher Website).