An update to our API has caused performance issues that are being actively investigated
Incident Report for Switcher Inc.
Resolved
The issue that caused the Switcher API outage has been resolved.

An alteration to our database to improve performance caused the database to be unavailable for several minutes while the alternation took place. While the deployment was tested in development and staging environments, the production environment behaved differently, likely due to the load already in place.

We have updated the code for our database alternations to keep the database online even during long-running operations.
Posted Jan 19, 2023 - 13:40 EST
Monitoring
A fix has been implemented and services should be restored. We're continuing to monitor services to ensure the fix has resolved the issue.
Posted Jan 19, 2023 - 13:14 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 19, 2023 - 13:00 EST
This incident affected: Services (Switcher API, Switcher Dashboard) and Apps (Switcher Studio App).