Delayed or Undeliverable Emails
Incident Report for Switcher Inc.
Resolved
The issue has been resolved and you should now start receiving emails.
Posted May 01, 2020 - 21:17 EDT
Identified
We have identified an issue that is causing emails sent from our system to no be delivered. We are currently working on a solution.

Email types include:
Password Resets
Email Verification
Team Invitations
Posted May 01, 2020 - 17:32 EDT
This incident affected: Services (Switcher API).